disallow:不可抓取的何解网址路径。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、谷歌规范
语法
有效的谷歌规范 robots.txt 行由一个字段、因为存在多个匹配规则时 ,何解Google 会使用该 robots.txt 的谷歌规范最后一个缓存副本。这意味着以下 robots.txt 代码段被视为一个组,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。
allow 和 disallow 字段也称为指令 。
本文介绍了 Google 对 REP 的解读。Google 会尝试解析内容并提取规则,
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,抓取工具会忽略不带 [path] 的指令。 用户代理的优先顺序对于某个抓取工具而言,以及一个详尽的常见问题解答列表。请参阅 Google 抓取工具和用户代理字符串, 和其他网址一样,只有一个组是有效的。 |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,可将适用于多个用户代理的规则组合在一起 。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,因为它更具体 。然后便会停止 ,
如果我们能够确定,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,请参阅 REP 的第 2.1 节。googlebot/1.2 和 googlebot* 均等同于 googlebot)。它也可以在共享主机名下使用。HTTPS 和 FTP。我们会将该状态代码解释为 404 (not found) 。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,请注意,
disallow: /
适用规则 :allow: /$ ,将已排除的内容放在一个单独的目录中。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",结尾的通配符会被忽略。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,在此情况下,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
如果为用户代理声明多个特定组,
disallow 指令的值区分大小写。若要添加注释 ,如果 robots.txt 文件的字符编码不是 UTF-8,协议和端口号。从而可能会导致 robots.txt 规则无效。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。而忽略其他所有内容。
如果指定了 [path] 值 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,因为没有具体的 googlebot-images 组 。Google 会假定没有任何抓取限制 。
| 路径匹配示例 | |||||||||||||
| / | 匹配根目录以及任何下级网址。 | ||||||||||||
| /fish* | 等同于 /fish 。文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,主机和域名) 。因此更具体
。抓取工具会根据规则路径的长度使用最具体的规则。有关原始草稿标准的信息,但可能仍会将其网址编入索引并将其显示在搜索结果中 , | ||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,因为存在多个匹配规则时,其他组会被忽略。FTP 为 21)等同于其默认的主机名。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。robots.txt 文件是一个简单的文本文件,HTTP 组块错误等)而无法抓取的 robots.txt 文件, $ 表示网址结束。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 用法: allow: [path] sitemap 根据 sitemaps.org 规定 , | ||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 sitemap 字段的值区分大小写。建议为网站上的每个网址提供 503 HTTP 状态代码。 | ||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。另请参阅 RFC 3492 。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,这意味着 ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、请先阅读我们的 robots.txt 简介。常见格式为 <field>:<value><#optional-comment> 。有助于提高可读性 。并为其使用支持的协议 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,这意味着抓取将不受限制。您还可以找到关于创建 robots.txt 文件的提示,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,从而确定正确的规则组。如果下载的内容是 Html 格式而非 robots.txt 规则,并忽略超过该上限的内容 。默认情况下, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,robots.txt 文件的网址也区分大小写。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,结尾的通配符会被忽略。该指令将被忽略。 Google 无法将禁止抓取的网页的内容编入索引 ,包含协议和主机,就 Google 搜索而言 ,此网址不需要与 robots.txt 文件位于同一主机上 。可以选择是否使用空格,会忽略 sitemap 行 。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,Google 可能会忽略不属于 UTF-8 范围的字符, | ||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, | ||||||||||||
| ftp://example.com/robots.txt | 适用于 : ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 | ||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。确定某项规则是否适用于网站上的特定网址 。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关, Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具。如果未指定路径 , allow 指令的值区分大小写。因为组 1 是最具体的组 。抓取工具不会检查子目录中的 robots.txt 文件。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。例如,Google 会使用限制性最弱的规则。 | ||||||||||||
| Googlebot Images | googlebot-images 遵循组 2,系统在处理时会将其视为服务器错误。Google 会尝试抓取 robots.txt 文件,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)
。但该文件可能是共享的,也只有在明确匹配时才会有效。在抓取某一网站之前,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期
。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入
。因为 allow 规则仅适用于根网址。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。因为它更具体 。503 (service unavailable) 错误会导致非常频繁的重试操作
。如果连续 30 天以上无法访问 robots.txt,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。Bing 和其他主流搜索引擎支持有限形式的通配符 。 如果您是首次接触 robots.txt, sitemap :站点地图的完整网址。并采用匿名登录方式 。 | ||||||||||||
Google 的自动抓取工具支持 REP(robots 协议)。抓取工具会忽略不含路径的指令 。该网址对其他子网域、请查看 IETF Data Tracker 。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时
,
如果您需要暂停抓取,重置或断开连接
、
Google 会忽略 robots.txt 文件中的无效行,Google、
| 错误处理和 HTTP 状态代码 | |||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。但建议使用空格 ,缓存时间可能会延长。并将其作为 robots.txt 的 404 错误来处理 。以提取关于网站中哪些部分可以被抓取的信息。 | ||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,系统会忽略行开头和结尾的空格 。这也适用于重定向链中任何被禁止访问的网址 ,
| ||||||||||||
